Virtua IT, d.o.o.
Kotnikova ulica 35
1000 Ljubljana
Slovenija

T: +386 590 91780
E: info@virtua-it.si

Skoraj eno leto nazaj, smo na tem blogu že pisali o Mikrotik IGMP Proxy. Ker so se od takrat zadeve nekoliko spremenile, tokrat ponavljam konfiguracijo, ki preverjeno deluje.
Predpostavke so naslednje:

  • Zunanji mrežni priključek se imenuje WAN
  • Notranji mrežni priključek se imenuje LAN
  • Vsi navedeni parametri veljejo za T-2 ponudnika, ostali imajo verjetno drugačne ip naslove in porte

Najprej postavimo IGMP proxy.

Tu moramo povedati predvsem kaj je znotraj in kaj zunaj:

/routing igmp-proxy interface
add alternative-subnets=172.0.0.0/8 disabled=no interface=WAN threshold=1 upstream=yes
add disabled=no interface=LAN threshold=1 upstream=no

Zanimiv je tudi parameter “alternative-subnets=172.16.0.0/12”. Gre za to, da T-2 oddaja multicast iz naslovov v tem območju, naš IP na javni strani je pa v nekem drugem območju. S to direktivo povemo Mikrotiku, naj vseeno posluša tudi v tem subnetu, ne le v tistem, kjer ima na tem interface nastavljen IP naslov.

Še opomba o samem naslovu 172.16.0.0/12. Zgleda, da T-2 uporablja strežnike v tem subnetu. Seveda ne zasedajo celega, ampak ker s tem ne delamo kakšne silne škode, sem kar celega navedel. Seveda je možno, da uporabljajo še katerega drugega, vendar to ni bilo opazit.

Nastavitev požarnega zidu

Nato moramo urediti še požarni zid, da bo dovolil te povezave:

/ip firewall filter

add action=accept chain=input comment=”Allow Broadcast Traffic” disabled=no dst-address-type=broadcast
add action=accept chain=input comment=”Allow IGMP” disabled=no protocol=igmp
add action=accept chain=input comment=”Allow T-2 IPtv” disabled=no protocol=udp src-address=172.16.0.0/12

Pozor: če boste kodo pejstali v Mikrotik, prosim prej zamenjajte narekovaje pri komentarjih. WordPress je tako fajn, da te narekovaje vedno popravi v bolj všečne in ne vem kako se to izklopi.

Za prvo vrstico nisem čisto prepričan, če je portebna – poskusite. Pri meni se zelo malo “Ujame”, tako da skoraj gotovo ni.

Tako, to je vse kar je potrebno narediti, potem pa seveda potrebujete še VLC predvajalnik in ustrezno Play listo. Eno sem našel tule: http://www.rula.net/t2/ ne vem, če je prav posodobljena.

Še beseda o WiFi in multicastu. Na kratko rečeno: ni podprto. Če želite gledati TV preko WiFi, potrebujete nepravo, ki bo multicast on-the-fly spremenila v unicast. To znajo že boljše dostopovne točke, recimo Aruba AP-105, pa tudi kakšna cenejša. Na odprtokodnih usmerjevalnikih lahko namestite poseben deamon, ki bo to naredil kot je treba. Vprašanje pa je, ali bo procesor na teh AP dovolj sposoben, da bo to naredil sproti. S težkim srcem pa tule priznavam, da Mikrotik tega ne zna, oziroma vsaj jaz ne vem, kako bi se to tu naredilo.

Multicast na Mikrotik WiFi je sedaj že nekaj časa podprt in deluje pravilno. Privzeto je vključen, tako da ne potrebuje posebne nastavitve.

Prijetno gledanje želim.

Spletno mesto uporablja piškotke zaradi boljše uporabniške izkušnje. Z uporabo naše spletne strani potrjujete, da se z njihovo uporabo strinjate. Več o tem.

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close