Virtua IT, d.o.o.
Kotnikova ulica 35
1000 Ljubljana
Slovenija

T: +386 590 91780
E: info@virtua-it.si

Ste se že kdaj znašli v nelagodni situaciji, ko je zaradi nekega neljubega dogodka oz. spleta okoliščin, odšel v elektronska nebesa vaš usmerjevalnik, na katerem ste en dan prej ustvarili obsežno konfiguracijo?Takšne stvari se dogajajo, zato je še kako pomembno redno ustvarjanje varnostnih kopij konfiguracije routerja, da sploh ne govorim o kopiji baze uporabniških podatkov v Usermanu.
Na srečo se na Mikrotik usmerjevalnikih lahko marsikaj avtomatizira s pomočjo skript ter urnika (scheduler).
V ta namen smo napisali skripto, ki ob določenem intervalu (napr. vsak dan) naredi backup konfiguracije in userman baze (če seveda obstaja), ter pošlje le-te na poljuben FTP strežnik.

Ta skripta deluje le na ROS od verzije v5 naprej saj pred tem ni bilo možno pošiljanje datoteke na ftp strežnik.

Kratek opis delovanja:

Ko se skripta izvede, ustvari najprej dve datoteki, konfiguracija.backup (/system backup save) in export_konfiguracije.rsc (/export). Nato preveri še, če na routerju obstaja paket Userman in v primeru da, potem naredi še backup uporabniške baze userman_db.umb.Nato vse te datoteke pošlje na FTP strežnik in jih shrani kot ImeRouterja_datum.KončnicaDatoteke (napr.: MojMTIK_21.feb.2012.backup).

Skripta:

:global ftp “ftp.naslov”
:global user “FTP_uporabnik”
:global password “FTP_geslo”
############################
:global name [/system identity get name]
:global date [/system clock get date]
:global day [:pick $date 4 6]
:global month [:pick $date 0 3]
:global year [:pick $date 7 11]

/system backup save name “conf”
/export file=”conf_export”

:delay 5s
/tool fetch src-path=”tedenski.backup”
    address=$ftp dst-path=(“$name” . “_” . “$day.$month.$year”.”.backup”)
    user=$user password=$password upload=yes mode=ftp
/tool fetch src-path=”tedenski_export.rsc”
    address=$ftp dst-path=(“$name” . “_” . “$day.$month.$year”.”.rsc”)
    user=$user password=$password upload=yes mode=ftp

:if ([/system package print count-only where name=user-manager]=1) do={
    :if ([/tool user-manager user print count-only]>0) do={
        /tool user-manager database save name=”userman_db”
        /tool fetch src-path=”userman_db.umb”
            address=$ftp dst-path=(“$name” . “_” . “$day.$month.$year”.”.umb”)
            user=$user password=$password upload=yes mode=ftp
        }
}

Primer scheduler za interval 1 dan:

/system scheduler
add disabled=no interval=$interval name=backup_remote on-event=”/system script run upload_backup”


					

Spletno mesto uporablja piškotke zaradi boljše uporabniške izkušnje. Z uporabo naše spletne strani potrjujete, da se z njihovo uporabo strinjate. Več o tem.

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close