V naslednjem članku bomo opisali dokaj pogosto rešitev, ko imamo v stanovanju napeljan od centralnega razvoda inštalacij le en UTP kabel do mesta, kjer se nahaja televizija in druga AV krama. Vsi seveda vemo, da na takem kraju potrebujemo nekje od 4 – 8 utp vtičnic, od katerih so nekatere vezane neposredno na ponudnika (set-top box in morda telefon), druge pa v lokalna omrežja, ki sta seveda najmanj 2 – 4 (odrasli, otroci, naprave, Katarina – za za službeni laptop – Katarina je v službi v večji slovenski banki, kjer jim Direct Access ne dela, če so računalniki na IPv6 omrežju)

Seveda se lahko princip smiselno uporablja tudi v podjetjih, kjer je zadnje čase omrežje pravzaprav enostavnejše od domačega.

Da ne bo preveč komplicirano, zajeli pa bomo vse elemente postavitve, tako da jo boste lahko doma z lahkoto razširili, predpostavimo naslednjo situacijo:

  • imamo T-2 optični priključek, ki ga vključimo v Mikrotik brez njihovega stikala (za to potrebujete le “single mode” SFP in morda pasivni optični adapter iz SC v LC, ki ga sestavite iz SC-SC ženskega spojnika in SC-LC povezovalnega kabla. Vse to dobite v naši trgovini).
  • Imamo mikrotik usmerjevalnik z optičnim portom, recimo RB-2011 ali RB-3011.
  • Pri televiziji imamo dostopovno točko s switchem, ki ima 5 priključkov, ali Mikrotik switch. Alternativno, imamo lahko pri televiziji katerokoli stikalo, ki podpira vlan, na misel pridejo cenejše izvedbe D-link stikal ali oprema proizvajalca Ubiquity networks.

Naši cilji pa so:

  • čim bolj efektivno in hitro pretvoriti omrežje, ki pride iz t-2 (javni internet, telefonija in televizija vse v privzetem VLAN) v naš vlan ID 10
  • naš LAN VLAN pretvoriti v VLAN ID 15
  • To dvoje združiti in poslati po enem kablu do televizije, kjer bomo to zopet razdružili in razdelili med porabnike, kakor kateri potrebuje.
  • Vse VLAN pretvorbe (vključno s tisto, kjer VLAN tag snamemo in nadaljujemo s tako imenovanim dostopnim ali Access priključkom) želimo izvesti v čipovju, brez sodelovanja procesorja

Taka konfiguracija nam bo prinesla dodatno prednost, to je, da bomo lahko lokalno na usmerjevalniku premoščali (bridge) najmanj dve omrežji v čipovju (za več bo verjetno zmanjkalo priključkov, sicer bi pa šlo). Privzeto je namreć mogoče (z uporabo master – slave ethernet port nastavitev) premostiti le eno omrežje v enem strojnem čipu, kar običajno pomeni na 5 ethernet priključkih (+ 1 sfp).

Še nekaj teorije in virov

V desnem delu navajam vire, ki so mi prišli prav pri konfiguraciji. Posebej uporaben je prispevek Daniela Starnowskega, ki precej demistificira uporabo switch čipa v Mikrotiku.

Daniel navaja nekaj dejstev, ki jih povzemam brez preverjajnj, zgleda da delujejo. Priporočam, da prezentacijo pogledate, zelo lepo je narisano, kaj se dogaja, če uporabljamo software bridge in kaj, če to namestimo s strojnim stikalom v čipu. Strnjeno gredo pa takole:

Zanimive povazave

Iz mikrotik navodil:

Prezentacija Daniel Starnowski, MUM Ljubljana 2016:

  • Ko začnemo uporabljat switch chip, je prvo vprašanje, kakšno vlogo še ima nastavitev master-port v nastavitvah /interface ethernet. Kaže, da z nastavitvijo master porta aktiviramo čip, tako na odvisnih (slave) priključkih, kot na master priključku. Od tu naprej so pravzaprav master in slave priključki enekovredni, edina razlika je, da konkreten promet (denimo s Torch orodjem) vidimo le na master portu. V zadnjih verzijah RouterOS vidimo ločen promet (torej števiko paketov in MB prenešenih v obeh smereh) tudi na slave portih, prej je bil ta pogled zagotovljen le kumulativno na master portu.
  • V običajnem delu z ethernet stikali v bistvu potrebujemo samo tri tipe nastavitev:
    1. Acces port – priključek namenjen računalnikom in podobni opremi, kjer pormet iz računalnika v switch “tagiramo”, ko pride iz switcha pa ga “odtagiramo”, tako da računalnik niti ne more vedeti, da je bil promet kdaj udeležen v VLAN.
    2. Trunk port – priključek, kjer po enem kablu prenašamo več VLAN in običajno nima privzetega VLAN. Te uporabljamo za povezave med stikali, in v virtualizacijskem okolju.
    3. Hybrid port – ima privzet VLAN, recimo naše LAN omrežje, ki zunaj switcha ni tagirano in enega ali več VLAN (recimo za telefonijo), ki je tagirano ustreznim VLAN tagom. Daniel v prezentaciji pravi, da porti tega tipa na Mikrotiku niso mogoči, kar je bilo verjetno res v času nastanka njegove prezentacije, sedaj pa zgleda deluje tudi to.
  • Zelo pomembno spoznanje je, da je znotraj switch chipa ves promet tagiran. Ko se tega navadimo, je konfiguracija precej enostavna.
  • Vse zgoraj omenjene nastavitve bodo veljale na priključkih in znotraj switch chipa. Kaj pa ko želimo s tem prometom delati kaj bolj kompliciranega od premoščanja? V tem primeru moramo promet poslati v “switch1-cpu” port. Ko to naredimo, se bo promet pojavil znotraj VLAN virtualnih priključkov (interfaces), ki jih definiramo znotraj RouterOS. Od tu naprej jim lahko določamo IP naslove in izvajamo vse višjenivojske opracije, ki smo jih vajeni od prej. Seveda pa se pri tem pojavi vprašanje, na katerem portu definiramo te “soft” vlan priključke. Meni bi se zdelo najbolj logično, da bi definirali nov soft bridge in VLAN priključke definirali na njem. Izkaže se, da naša zgodba v tem primeru ne deluje. Zato v tem primeru VLAN priključke definiramo na “master” portu. Pri tem ni pomembno, ali določen VLAN na tem portu kasneje tudi uporabljamo ali ne – to definiramo na nivoju switch chipa. Recimo temu, da na ta način VLAN vmesnike le deklariramo.

Kako torej nastavimo mikrotik, da bo delovalo zgoraj opisano?

V spodnji nastavitvi bomo imeli:

port 0 – SFP – Acces port vlan 10 – WAN
port 1 – 3 – Acces port vlan 15 – LAN
port 4 – trunk VLAN 10 in 15
port 5 – Hybrid, default VLAN iz 15, + tagiran promet na VLAN 10

#Nastavimo ethernet porte, da vključimo swithc chip: 

/interface ethernet set [ find default-name=sfp1 ] master-port=ether2 name="T-2 Internet" 
set [ find default-name=ether1 ] master-port=ether2 name="ether1 - LAN" 

#Ether 2 pustimo pri miru, nastavimo le ime 

set [ find default-name=ether2 ] name="ether2 - LAN" 
set [ find default-name=ether3 ] master-port=ether2 name="ether3 - LAN" 
set [ find default-name=ether4 ] master-port=ether2 name="ether4 - Trunk" 
set [ find default-name=ether5 ] name="ether5 - Hybrid" 

# pri portih nastavljamo VLAN, uporabljamo ID namesto imen, 11 je CPU za switch 1: 

/interface ethernet switch port 
set 0 default-vlan-id=10 vlan-header=always-strip vlan-mode=secure 
set 1 default-vlan-id=15 vlan-header=always-strip vlan-mode=secure 
set 2 default-vlan-id=15 vlan-header=always-strip vlan-mode=secure 
set 3 default-vlan-id=15 vlan-header=always-strip vlan-mode=secure 
set 4 vlan-header=leave-as-is vlan-mode=secure 
set 5 default-vlan-id=15 vlan-header=add-if-missing vlan-mode=secure 
set 11 vlan-mode=secure 

# Nastavimo še VLANe na porte 

/interface ethernet switch vlan 
add independent-learning=yes ports="T-2 Internet,ether4 - Trunk,ether5 - Hybrid,switch1-cpu" switch=switch1 vlan-id=10 
add independent-learning=yes ports="ether1 - LAN,ether2 - LAN,ether3 - LAN,ether4 - Trunk,ether5 - Hybrid,switch1-cpu" \ switch=switch1 vlan-id=15

Opomba

Konfiguracijo sem v tekstu nekoliko popravil, napisanega še nisem imel časa stestirat, zato morda ne bo delalo v prvo. Če opazite kakšno napako, prosim sporočite, bomo popravili.

Kako od tu naprej?

Od tu naprej je vse enako, kot prej. LAN Vlan dodate recimo v LAN bridge, na WAN Vlan pa lahko kar nastavite DHCP klienta, ki bo od t-2 dobil javni ip.

#Nastavimo ethernet porte, da vključimo swithc chip: /interface ethernet set [ find default-name=sfp1 ] master-port=ether2 name="T-2 Internet" set [ find default-name=ether1 ] master-port=ether2 name="ether1 – LAN" #Ether 2 pustimo pri miru, nastavimo le ime set [ find default-name=ether2 ] name="ether2 – LAN" set [ find default-name=ether3 ] master-port=ether2 name="ether3 – LAN" set [ find default-name=ether4 ] master-port=ether2 name="ether4 – Trunk" set [ find default-name=ether5 ] name="ether5 – Hybrid" # pri portih nastavljamo VLAN, uporabljamo ID namesto imen, 11 je CPU za switch 1: /interface ethernet switch port set 0 default-vlan-id=10 vlan-header=always-strip vlan-mode=secure set 1 default-vlan-id=15 vlan-header=always-strip vlan-mode=secure set 2 default-vlan-id=15 vlan-header=always-strip vlan-mode=secure set 3 default-vlan-id=15 vlan-header=always-strip vlan-mode=secure set 4 vlan-header=leave-as-is vlan-mode=secure set 5 default-vlan-id=15 vlan-header=add-if-missing vlan-mode=secure set 11 vlan-mode=secure Nastavimo še VLANe na porte /interface ethernet switch vlan add independent-learning=yes ports="T-2 Internet,ether4 – Trunk,ether5 – Hybrid,switch1-cpu" switch=switch1 vlan-id=10 add independent-learning=yes ports="ether1 – LAN,ether2 – LAN,ether3 – LAN,ether4 – Trunk,ether5 – Hybrid,switch1-cpu" \ switch=switch1 vlan-id=15
Share This

Spletno mesto uporablja piškotke zaradi boljše uporabniške izkušnje. Z uporabo naše spletne strani potrjujete, da se z njihovo uporabo strinjate. Več o tem.

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close