Virtua IT, d.o.o.
Kotnikova ulica 35
1000 Ljubljana
Slovenija

T: +386 590 91780
E: info@virtua-it.si

Večkrat smo že prejeli vprašanje, ki se je nanašalo na to, kako bi lahko na Mikrotiku vklopil in izklopil delovanje WiFi ob določeni uri.
Zato objavljamo dve rešitvi:

Prva varianta: WiFi access list

Z WinBox se povežite na router in najdite nastavitev

 

Access List settings

Nahaja se znotraj Wireless nastavitev, boste že našli. Tu nastavite, tako kot je na sliki, seveda z vašimi časi. Poskrbeti morate tudi, da je vaša ura na Mikrotiku točno nastavljena in da je izbrana pravilna časovna cona. Če ne veste o čem govorim, bo najbolje, da odprete terminalsko okno (New Terminal” ) in notri spejstate tole kodo:

/system ntp client set enabled=yes primary-ntp=193.2.1.66 secondary-ntp=193.2.1.92 mode=unicast

/system clock set time-zone-name=”Europe/Ljubljana”

Koda bo nastavila pravilno časovno cono, čas pa bo sinhronizirala iz Arnesovih časovnih strežnikov.

Kako tole deluje?

Videli boste, da bo Mikrotik še vedno oddajal SSID, vendar priklop nanj v času, ko tega ne boste dovolili, ne bo več mogoč. Tu lahko nastavite tudi izjeme, tako da pred tem vnosom naredite še kakšnega, bolj podrobnega, kjer recimo klientu z določenim MAC naslovom dovolite prijavo tudi izven teh terminov.

V sistemskem logu boste lahko spremljali tudi zavrnjene dostope, zato je meni ta način ljubši od spodnjega.

Druga varianta: Skripta

Druga možnost je, da naredimo posebno skripto, ki vkljaplja celoten interface. Prednost te skripte je v tem, da vse skupaj ugasnemo, torej niti SSID ne oddajamo več. Poleg tega lahko skripto poljubno zakompliciramo, naredimo izjeme in podobno..

:global izklop “22:00:00”

:global vklop “08:00:00”

:global WlanName “wlan1”

#########################################

/system scheduler

add interval=1d name=wifi_off on-event=”/interface wireless disable $WlanName”

    start-time=$izklop

add interval=1d name=wifi_on on-event=”/interface wireless enable $WlanName”

    start-time=$vklop

To je to, parametri so očitni, glejte le, da se vaš Wlan vmesnik pravilno imenuje, pa bo.

Hvala Urošu, ki se je potrudil tole tudi stestirat 🙂

 

Spletno mesto uporablja piškotke zaradi boljše uporabniške izkušnje. Z uporabo naše spletne strani potrjujete, da se z njihovo uporabo strinjate. Več o tem.

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close